[Webkit-unassigned] [Bug 47386] Need implementation of ChromeClient windowRect related functions.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 9 12:54:50 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47386





--- Comment #9 from mitz at webkit.org  2010-10-09 12:54:50 PST ---
(From update of attachment 70336)
View in context: https://bugs.webkit.org/attachment.cgi?id=70336&action=review

I’d prefer “window frame” to “window rect”. The latter doesn’t mean much.

> WebKit2/Shared/API/c/WKGeometry.h:49
> +  	WKSize size;

Not enough indentation

> WebKit2/UIProcess/PageClient.h:57
> +    virtual WebCore::FloatRect transformRectToDeviceSpace(const WebCore::FloatRect&) = 0;
> +    virtual WebCore::FloatRect transformRectToUserSpace(const WebCore::FloatRect&) = 0;

Is “rect” necessary in these methods’ names?

> WebKit2/UIProcess/WebPageProxy.cpp:54
> +#include <WebCore/FloatRect.h>
>  
>  #include "WKContextPrivate.h"

Not sure why the #includes are separated like this.

> WebKit2/UIProcess/WebPageProxy.h:283
> +    void windowRect(WebCore::FloatRect&);

getWindowRect would be a better name.

> WebKit2/UIProcess/WebUIClient.cpp:32
>  #include <WebCore/IntSize.h>
> +#include <WebCore/FloatRect.h>

F < I

> WebKit2/UIProcess/win/WebView.cpp:37
>  #include <WebCore/IntRect.h>
> +#include <WebCore/FloatRect.h>

F < I

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list