[Webkit-unassigned] [Bug 27165] Connections-per-host should be tracked closer to the ResourceHandle level, not the Cache

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 8 16:52:08 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=27165





--- Comment #26 from Adam Barth <abarth at webkit.org>  2010-10-08 16:52:07 PST ---
(From update of attachment 70314)
View in context: https://bugs.webkit.org/attachment.cgi?id=70314&action=review

> WebKit/mac/WebView/WebView.mm:624
>  - (void)_dispatchPendingLoadRequests
>  {
> -    cache()->loader()->servePendingRequests();
> +    resourceLoadScheduler()->servePendingRequests();
>  }

I wonder why only Mac does this.

> WebCore/loader/ResourceLoadScheduler.cpp:66
> +ResourceLoadScheduler::HostInformation* ResourceLoadScheduler::hostForURL(const KURL& url, bool createIfNotFound)

using an enum here is probably slightly more readable at the callsites.

> WebCore/loader/ResourceLoadScheduler.cpp:71
> +    RefPtr<HostInformation> host;

Is there any reason to declare this up here instead of on line 74 where it's initialized?

> WebCore/loader/ResourceLoadScheduler.cpp:153
> +    HostMap::iterator i = m_hosts.begin();

We'd usually call this variable iter to remind ourselves that it's not an index.

> WebCore/loader/ResourceLoadScheduler.cpp:158
> +    for (unsigned n = 0; n < hostsToServe.size(); ++n) {

We'd usually call this one "i" because it is an index.  "n" is usually a constant and the total number of things.

> WebCore/loader/ResourceLoadScheduler.h:34
> +namespace WebCore {

Missing a blank line after this line.

> WebCore/loader/loader.cpp:-133
> -        AtomicString hostName = url.host();

Does it matter that this used to be an AtomicString?

> WebCore/loader/loader.cpp:225
> -            m_requestsLoading.remove(loader);
>              loader->clearClient();
> +            m_requestsLoading.remove(loader);

Why this re-ordering?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list