[Webkit-unassigned] [Bug 47280] [Qt] RunLoop implementation for WTR

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 6 11:20:19 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47280


Kenneth Rohde Christiansen <kenneth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #69963|review?                     |review+
               Flag|                            |




--- Comment #2 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2010-10-06 11:20:19 PST ---
(From update of attachment 69963)
View in context: https://bugs.webkit.org/attachment.cgi?id=69963&action=review

> WebKitTools/WebKitTestRunner/qt/TestControllerQt.cpp:38
> +class RunUntilLoop : public QObject {

Run until what? a condition? RunSingle?

> WebKitTools/WebKitTestRunner/qt/TestControllerQt.cpp:42
> +    static void start(bool& done)

ah seems to be a condition, I guess RunUntilConditionLoop would be a better name.

> WebKitTools/WebKitTestRunner/qt/main.cpp:51
> +        m_controller = new WTR::TestController(m_argc, const_cast<const char**>(m_argv));

leaking m_controller?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list