[Webkit-unassigned] [Bug 47256] Adding C api for comboboxes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 6 04:42:53 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47256





--- Comment #1 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2010-10-06 04:42:52 PST ---
(In reply to comment #0)
> Here goes a first proposal for the C api to be used for combobox handling in webkit2. Comments are very welcome.
> 
> 
> typedef const struct OpaqueWKCombobox* WKComboboxRef;

What about WKSelectPopupRef. It is for dealing with select input and it is supposed to render on top of the web contents.

> WK_EXPORT void WKComboboxDidHide(WKComboboxRef combobox);

Is this like a "inform did hide"? I think we need a better name for that one.

> 
> WK_EXPORT int WKComboboxGetItemCount(WKComboboxRef combobox);
> WK_EXPORT bool WKComboboxGetIsMultiple(WKComboboxRef combobox);

SupportsMultiplySelections? I do not think it is clear what "IsMultiple" means.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list