[Webkit-unassigned] [Bug 47121] need way to measure size of JITed ARM code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 5 08:38:57 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47121


Geoffrey Garen <ggaren at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #69697|review?                     |review-
               Flag|                            |




--- Comment #2 from Geoffrey Garen <ggaren at apple.com>  2010-10-05 08:38:57 PST ---
(From update of attachment 69697)
View in context: https://bugs.webkit.org/attachment.cgi?id=69697&action=review

This patch looks good, but I think it's worth doing those minor style improvements before landing.

> JavaScriptCore/assembler/LinkBuffer.h:288
> +        static unsigned int linkCnt = 0;
> +        static unsigned int totalInitialSize = 0, totalFinalSize = 0;

WebKit style is just "unsigned", not "unsigned int".

> JavaScriptCore/assembler/LinkBuffer.h:289
> +        linkCnt++;

WebKit style is to use full words in names instead of abbreviations: "linkCount".

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list