[Webkit-unassigned] [Bug 46532] Add LowPass2FilterNode files

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 4 14:59:31 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=46532


Kenneth Russell <kbr at google.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #69689|review?                     |review-
               Flag|                            |




--- Comment #5 from Kenneth Russell <kbr at google.com>  2010-10-04 14:59:31 PST ---
(From update of attachment 69689)
View in context: https://bugs.webkit.org/attachment.cgi?id=69689&action=review

Sorry I didn't catch the m_biquadProcessor issue earlier but please change it here as well as in HighPass2FilterNode.

> WebCore/webaudio/LowPass2FilterNode.cpp:38
> +    m_processor = lowpassFilter.release();

Per below, the weak m_biquadProcessor pointer is very confusing. Please change this to "m_processor = adoptPtr(...)" and add a helper function to fetch the processor as a BiquadProcessor.

> WebCore/webaudio/LowPass2FilterNode.h:48
> +    BiquadProcessor* m_biquadProcessor;

This weak pointer makes the lifetime of this object confusing. Make this a helper function "BiquadProcessor* biquadProcessor()" returning a static_cast of the result of processor().

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list