[Webkit-unassigned] [Bug 46937] [chromium] Minor naming cleanup in WebDragData

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 1 11:29:39 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=46937





--- Comment #7 from Ryosuke Niwa <rniwa at webkit.org>  2010-10-01 11:29:39 PST ---
(From update of attachment 69490)
View in context: https://bugs.webkit.org/attachment.cgi?id=69490&action=review

(In reply to comment #5)
> (From update of attachment 69485 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=69485&action=review
> 
> > WebKit/chromium/ChangeLog:14
> > +        The list of methods that have been renamed:
> > +        * hasFileNames() -> containsFilenames()
> > +        * fileNames() -> filenames()
> 
> I think Ryosuke was saying that you can put this in the section below.  The : after the method names is supposed to be space to write comments about how you modified the method.

Yup.  That's what I meant.  Sorry I should have been more clear.

> WebKit/chromium/src/WebDragData.cpp:139
> +    return containsFilenames();
> +}
> +
> +void WebDragData::fileNames(WebVector<WebString>& fileNames) const
> +{
> +    filenames(fileNames);
> +}
> +
> +void WebDragData::setFileNames(const WebVector<WebString>& fileNames)
> +{
> +    return setFilenames(fileNames);
> +}
> +
> +void WebDragData::appendToFileNames(const WebString& fileName)
> +{
> +    return appendToFilenames(fileName);
> +}
> +
> +bool WebDragData::containsFilenames() const
> +{

Ah! this is nice.  You don't have to move the code anymore!

Otherwise LGTM but I'm not a reviewer yet.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list