[Webkit-unassigned] [Bug 46624] Web Inspector: implement pausing on event listeners (back-end part)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 1 11:17:36 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=46624





--- Comment #14 from Yury Semikhatsky <yurys at chromium.org>  2010-10-01 11:17:35 PST ---
(From update of attachment 69479)
View in context: https://bugs.webkit.org/attachment.cgi?id=69479&action=review

> WebCore/inspector/InspectorController.cpp:1689
> +        m_nativeBreakpoints.set(*breakpointId, "XHR");

Please extract this into a constant.

> WebCore/inspector/InspectorController.h:396
> +    HashMap<String, unsigned int> m_eventNamesMap;

The map name should reflect what is stored in it. Now it's unclear what the values in this map are. Please rename.

> WebCore/inspector/InspectorInstrumentation.cpp:78
> +    while (!stack.isEmpty() && stack.last() >= s_minCallDepth)

I really don't like this mess with stack of callstack depths and s_minCallDepth. The alternative approach we discussed offline may be better.

> WebCore/inspector/InspectorInstrumentation.cpp:231
> +    if (!inspectorController->shouldBreakOnXMLHttpRequest(url))

The logic is getting spread over both InspectorInstrumentation and InspectorController without a clear border. I still think that we should reconsider the role of InspectorInstrumentation and make it a thin interface to IC used by the rest of WebCore.

> WebCore/inspector/InspectorTimelineAgent.h:80
> +    int id() { return m_id; }

This is not used, please remove.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list