[Webkit-unassigned] [Bug 25770] [chromium] Crash in FontFallbackList::determinePitch(const Font* font)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 30 15:41:19 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=25770


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #74209|review?                     |review+
               Flag|                            |




--- Comment #4 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-11-30 15:41:19 PST ---
(From update of attachment 74209)
View in context: https://bugs.webkit.org/attachment.cgi?id=74209&action=review

R=me, but it sure would be nice to find a way to share code with the PLATFORM(WIN) port.

> WebCore/platform/graphics/chromium/FontCacheChromiumWin.cpp:426
> +static SimpleFontData* fontDataFromDescriptionAndLogFont(FontCache* fontCache, const FontDescription& fontDescription, const LOGFONT& font, wchar_t* outFontFamilyName)

nit: it is normally nice to put helper functions at the top of the file, so as not
to break up the flow of class method implementations.  this doesn't cause a readability
problem in this case, but often once a static method is added like this, it becomes
an invitation for more people to add static functions like this, and pretty soon the
organization of a .cpp file is lost.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list