[Webkit-unassigned] [Bug 48697] Provide means to store shadow DOM nodes on Element

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 29 19:04:47 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=48697





--- Comment #12 from Dimitri Glazkov (Google) <dglazkov at chromium.org>  2010-11-29 19:04:46 PST ---
(In reply to comment #11)
> (From update of attachment 74038 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=74038&action=review
> 
> > WebCore/dom/Element.cpp:895
> > +void Element::removedFromTree(bool deep)
> 
> Just for curious: is the order correct?
> In a naive view, ContainerNode::removedFromTree() should be called afte shadow->removeFromTree() because
> it should be reverse order of what insertedIntoTree() does.
> 
> > WebCore/dom/Element.cpp:@
> >  void Element::detach()
> 
> Same question as one for removedFromTree().

Ah, good question. Think of shadowRoot as an extra child. The order in which the children are inserted/attached is the same (and not the reverse) as their removal/detachment.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list