[Webkit-unassigned] [Bug 48697] Provide means to store shadow DOM nodes on Element

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 29 17:48:59 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=48697





--- Comment #11 from MORITA Hajime <morrita at google.com>  2010-11-29 17:48:58 PST ---
(From update of attachment 74038)
View in context: https://bugs.webkit.org/attachment.cgi?id=74038&action=review

> WebCore/dom/Element.cpp:895
> +void Element::removedFromTree(bool deep)

Just for curious: is the order correct?
In a naive view, ContainerNode::removedFromTree() should be called afte shadow->removeFromTree() because
it should be reverse order of what insertedIntoTree() does.

> WebCore/dom/Element.cpp:@
>  void Element::detach()

Same question as one for removedFromTree().

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list