[Webkit-unassigned] [Bug 50080] [Qt] Support a QNetworkAccessManager affined to a different thread.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 26 02:55:46 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=50080





--- Comment #4 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2010-11-26 02:55:46 PST ---
(From update of attachment 74877)
View in context: https://bugs.webkit.org/attachment.cgi?id=74877&action=review

> WebCore/ChangeLog:37
> +        * platform/network/qt/NAMManipulator.cpp: Added.
> +        (WebCore::NAMManipulator::NAMManipulator):
> +        (WebCore::NAMManipulator::localSetCookies):
> +        (WebCore::NAMManipulator::localCookiesForUrl):
> +        (WebCore::NAMManipulator::localWillLoadFromCache):
> +        (WebCore::ReplyManipulator::ReplyManipulator):
> +        (WebCore::ReplyManipulator::~ReplyManipulator):
> +        (WebCore::ReplyManipulator::localGet):
> +        (WebCore::ReplyManipulator::localPost):
> +        (WebCore::ReplyManipulator::localHead):
> +        (WebCore::ReplyManipulator::localPut):
> +        (WebCore::ReplyManipulator::localDeleteResource):
> +        (WebCore::ReplyManipulator::localCustomRequest):
> +        (WebCore::ReplyManipulator::localAbort):
> +        (WebCore::ReplyManipulator::localForwardData):
> +        (WebCore::ReplyManipulator::localSetForwardingDefered):
> +        (WebCore::ReplyManipulator::localMirrorMembers):
> +        (WebCore::ReplyManipulator::localSetReply):
> +        * platform/network/qt/NAMManipulator.h: Added.

For new files you do not need to show the methods. You can just cut this out from the ChangeLog

> WebCore/platform/network/qt/NAMManipulator.cpp:30
> +static int dummyStaticVar1 = qRegisterMetaType<QFutureInterface<bool> >("QFutureInterface<bool>");
> +static int dummyStaticVar2 = qRegisterMetaType<QFutureInterface<QList<QNetworkCookie> > >("QFutureInterface<QList<QNetworkCookie> >");
> +

Could we find better names for this or at least add a comment?

> WebCore/platform/network/qt/NAMManipulator.cpp:97
> +    if (m_reply)
> +        delete m_reply;
> +}

Just do delete m_reply. delete handles null-pointers :-)

> WebCore/platform/network/qt/NAMManipulator.h:60
> +signals:

We probably want to use Q_SIGNALS etc

> WebCore/platform/network/qt/QNetworkReplyHandler.cpp:512
> +    connect(m_reply, SIGNAL(finished()),
> +            this, SLOT(finish()), SIGNAL_CONN);

Those should really be one liners :-)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list