[Webkit-unassigned] [Bug 49691] [NRWT] Remove a 'uri' member from TestInput class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 17 17:13:46 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=49691





--- Comment #3 from Dirk Pranke <dpranke at chromium.org>  2010-11-17 17:13:46 PST ---
(From update of attachment 74162)
View in context: https://bugs.webkit.org/attachment.cgi?id=74162&action=review

LGTM otherwise.

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/dump_render_tree_thread.py:-175
> -    test_input.uri = port.filename_to_uri(test_input.filename).strip()

When you do make run_test() take a single input, just stuff this down into the port/* implementations so that the ports that do need to convert the test name to the uri can do so, and the ports that don't (e.g., the test port, the dryrun port), don't need to convert back.

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/dump_render_tree_thread.py:175
> +    uri = port.filename_to_uri(test_input.filename).strip()

Nit: You don't actually need the strip() . filename_to_uri() doesn't append any whitespace. I'm not sure why this crept in at some point, and I've removed it in the patches-that-have-not-yet-been-uploaded-for-review :)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list