[Webkit-unassigned] [Bug 48812] FrameLoader::checkLoadCompleteForThisFrame uses wrong history item

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 17 11:23:36 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=48812





--- Comment #25 from Charles Reis <creis at chromium.org>  2010-11-17 11:23:35 PST ---
(From update of attachment 73550)
View in context: https://bugs.webkit.org/attachment.cgi?id=73550&action=review

>> WebCore/loader/FrameLoader.cpp:2385
>> +                        && pdl->triggeringAction().historyItem() == page->backForward()->currentItem()) {
> 
> Why do we need the isEmpty check? Presumably if the action is empty then the history item will be 0. Can currentItem be 0?
> 
> I’d prefer to not have the isEmpty function.

Sure, done.

>> WebCore/loader/NavigationAction.h:48
>> +        NavigationAction(const KURL&, FrameLoadType, bool isFormSubmission, PassRefPtr<Event>, PassRefPtr<HistoryItem>);
> 
> These are sorted in a strange order that makes it hard to read them. Also, I think we can use default argument values to cut down a bit on the overloading. Both PassRefPtr<Event> and PassRefPtr<HistoryItem> can have a default value of 0.

Good idea.  I've simplified and reordered it a bit, avoiding the need to pass false or 0 at the call sites.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list