[Webkit-unassigned] [Bug 25678] [GTK] Implement ROLE_COMBO_BOX

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 17 09:19:42 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=25678


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #74116|review?                     |review-
               Flag|                            |




--- Comment #5 from Martin Robinson <mrobinson at webkit.org>  2010-11-17 09:19:42 PST ---
(From update of attachment 74116)
View in context: https://bugs.webkit.org/attachment.cgi?id=74116&action=review

Nice patch. I have a couple questions...

> WebCore/ChangeLog:23
> +        of that methor to an overriden version of stringValue(), which is

methor -> method

> WebCore/accessibility/AccessibilityMenuListOption.cpp:113
> +String AccessibilityMenuListOption::stringValue() const

I'm not sure about the naming here. Maybe Chris can give the nod.

> WebCore/accessibility/gtk/AccessibilityObjectWrapperAtk.cpp:768
> +        const Vector<Element*> listItems = selectNode->listItems();
>  
> -    // TODO: Combo boxes
> +        if (selectedIndex < 0 || selectedIndex >= (int)listItems.size())

Is it possible for the selectedIndex to be > listeItems.size()? It doesn't look like it after staring at SelectElement::selectedIndex. If you still need to cast to int, be sure to use a static_cast.

> WebCore/platform/gtk/PopupMenuGtk.cpp:65
> -    int x, y;
> -    gdk_window_get_origin(gtk_widget_get_window(GTK_WIDGET(view->hostWindow()->platformPageClient())), &x, &y);
> +    int x = 0;
> +    int y = 0;
> +    GdkWindow* window = gtk_widget_get_window(GTK_WIDGET(view->hostWindow()->platformPageClient()));
> +    if (window)
> +        gdk_window_get_origin(window, &x, &y);

Is this change related?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list