[Webkit-unassigned] [Bug 49526] [WK2][Qt] WebKit2 implementation of tiled backing store

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 15 04:35:55 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=49526





--- Comment #3 from Andreas Kling <kling at webkit.org>  2010-11-15 04:35:55 PST ---
(In reply to comment #2)
> You have UpdateTile and CancelTileUpdate? Maybe the former should be called RequestTileUpdate?

Okydoky.

> > WebKit2/Shared/CoreIPCSupport/DrawingAreaProxyMessageKinds.h:44
> > +    TileUpdatesComplete,
> 
> Maybe a better name can be found, as it is not clear what it complete. a current round of tile updates?

Indeed. It fires when there are no more tile update requests pending.
Any ideas for something better? RequestedTilesUpdated?

> > WebKit2/UIProcess/API/qt/qgraphicswkview.cpp:52
> > +    void _q_scaleChanged();
> > +    void commitScale();
> 
> Why is one with _q_? and the other not? Should both be, or none be?

The _q_ is Qt convention for handling the public class's signal in the private class. We could call it e.g. onScaleChanged() instead, I don't really mind.

> > WebKit2/UIProcess/API/qt/qgraphicswkview.cpp:78
> > +    d->page->setViewportSize(geometry().size().toSize());
> 
> does this make sense? What about setResizesToConten....

Hmhmhm.. you want to hardcode setRTC in tiling mode?

> > WebKit2/UIProcess/API/qt/qgraphicswkview.cpp:314
> > +void QGraphicsWKView::commitScaleChange()
> 
> You have begin and commit? Submit, commit? or begin, end?

Will change to begin/end.

> This is using old API, you should be able to call sent(DrawingAreaMessage::SetSize(viewSize) I beleive

The necessary code isn't generated for this class. Fixable of course, but I'd rather do that in a separate patch.

> > WebKit2/UIProcess/TiledDrawingAreaProxy.cpp:125
> > +void TiledDrawingAreaProxy::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageID messageID, CoreIPC::ArgumentDecoder* arguments)
> > +{
> > +    switch (messageID.get<DrawingAreaProxyMessage::Kind>()) {
> > +    case DrawingAreaProxyMessage::TileUpdated: {
> 
> Can you verify it this is the way it is still done?

It is.

> WebKit2/UIProcess/TiledDrawingAreaProxy.cpp:182
> > +        static const double ipcTimeout = 2.0;
> 
> Is ipcTimeout the best name?

Maybe not.. I'll call it tileUpdateTimeout instead then.

> > WebKit2/UIProcess/TiledDrawingAreaProxy.cpp:349
> > +    IntRect visibleRect = mapFromContents(webViewVisibleRect());
> 
> I think we need to hook this up to visibleContentRect from webcore.

Ok.

> > WebKit2/UIProcess/TiledDrawingAreaProxy.cpp:477
> > +    bool resized = false;
> 
> wasResized?

Ok.

> > WebKit2/UIProcess/TiledDrawingAreaProxy.h:92
> > +    void getKeepAndCoverAreaMultipliers(WebCore::FloatSize& keepMultiplier, WebCore::FloatSize& coverMultiplier)
> 
> Remove get?

I'd rather not

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list