[Webkit-unassigned] [Bug 49018] [GTK] response.isNull() assert when using directory file URI

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 8 10:49:05 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=49018





--- Comment #6 from Sergio Villar Senin <svillar at igalia.com>  2010-11-08 10:49:06 PST ---
Nice catch!. Some comments to your patch

> WebCore/platform/network/soup/ResourceHandleSoup.cpp:-694
> -    if (equalIgnoringCase(protocol, "http") || equalIgnoringCase(protocol, "https")) {

Although not directly related to the bug I think you can indeed include style fixes.

> WebCore/platform/network/soup/ResourceHandleSoup.cpp:-699
> -    if (equalIgnoringCase(protocol, "file") || equalIgnoringCase(protocol, "ftp") || equalIgnoringCase(protocol, "ftps")) {

If I am not wrong, this has nothing to do with the bug so, I guess you either should attach another patch or maybe a different bug, Martin?

> WebCore/platform/network/soup/ResourceHandleSoup.cpp:793
>      GOwnPtr<GError> error;

You're indeed right, we're not notifying about the didReceiveResponse for directories but:

1) why don't you just remove the condition in line 534 then?, and
2) in order to keep the consistency of the new design for ResourceHandleSoup, the didReceiveResponse should be called before any read, so it's better to keep the check in sendRequestCallback.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list