[Webkit-unassigned] [Bug 25444] SelectionStart, selectionEnd properties return wrong values when the selection is in a form input

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 5 08:53:34 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=25444





--- Comment #11 from Alexey Proskuryakov <ap at webkit.org>  2010-11-05 08:53:34 PST ---
I'm deferring to others for in-depth review, but have a few comments in passing:

+    if (Node* sNode = n->shadowAncestorNode()) {

"sNode" is not a good name - if "s" prefix ever means anything, that's "static".

> A comment in HTMLInputElement.idl says that this is a WinIE & FireFox extension. Is that wrong?
> Please fix either the comment or the test.

You addressed this comment, but without answering the question directly. Did you find out that selectionStart/selectionEnd work in IE, after all? Does the final test pass in both Firefox and IE?

+        if (elt.selectionStart == s1 && elt.selectionEnd == e1)
+            endResult = 1;
+        else
+            endResult = 0;

Doesn't this mean that the overall PASS/FAIL result only depends on the last subtest?

+        if (window.layoutTestController) {
+            layoutTestController.waitUntilDone();
+        }

No need for waitUntilDone/notifyDone - the test runs from onload, and doesn't set any timeouts. I'd also suggest putting dumpAsText at the very beginning of the script, so that it's executed during parsing.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list