[Webkit-unassigned] [Bug 48450] [Qt] Extend the Platform Plugin to define the padding of HitTestResult

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 2 16:59:47 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=48450





--- Comment #19 from Andre Pedralho <andre.pedralho at gmail.com>  2010-11-02 16:59:46 PST ---
(In reply to comment #16)
> (From update of attachment 72761 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=72761&action=review
> 
> I don't understand why you make such a complicated example, but well :-) I would just have done
> 
> return 10; // Use 10 as padding in each direction.
> 
> This seems a bit overengineered... in real life you mostly want the same padding in each direction, but maybe a bit more padding in the top, but that could easily be implemented just in the histTestPaddingForTouch method
> 
> like
> 
> if (direction == PaddingDirection::Up)
>     return 15;
> return 8;
> 
> or similar.
>

// Use 10 as padding in each direction but Up.
if (direction == QWebTouchInteraction::Up)
    return 15;
return 10;

Better?

> > WebKit/qt/examples/platformplugin/qwebkitplatformplugin.h:123
> > +        Touch
> 
> Is Touch a good name here... maybe TouchInteraction ? I'm just thinking out loud... maybe others have comments.
TouchInteraction is a better name but it is also the class name, then it conflicts. Suggestions?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list