[Webkit-unassigned] [Bug 39747] New: qt_runtime.cpp has coding-style errors

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 26 09:33:29 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39747

           Summary: qt_runtime.cpp has coding-style errors
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: All
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: WebKit Qt
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: agbakken at gmail.com


WebCore/bridge/qt/qt_runtime.cpp:34:  Alphabetical sorting problem.  [build/include_order] [4]
WebCore/bridge/qt/qt_runtime.cpp:68:  Should have a space between // and comment  [whitespace/comments] [4]
WebCore/bridge/qt/qt_runtime.cpp:69:  Should have a space between // and comment  [whitespace/comments] [4]
WebCore/bridge/qt/qt_runtime.cpp:72:  This { should be at the end of the previous line  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:74:  Missing space before {  [whitespace/braces] [5]
WebCore/bridge/qt/qt_runtime.cpp:75:  Missing space before {  [whitespace/braces] [5]
WebCore/bridge/qt/qt_runtime.cpp:137:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:148:  Declaration has space between type name and * in JSObject *object  [whitespace/declaration] [3]
WebCore/bridge/qt/qt_runtime.cpp:149:  One space before end of line comments  [whitespace/comments] [5]
WebCore/bridge/qt/qt_runtime.cpp:149:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:193:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
WebCore/bridge/qt/qt_runtime.cpp:192:  Missing space before ( in switch(  [whitespace/parens] [5]
WebCore/bridge/qt/qt_runtime.cpp:245:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
WebCore/bridge/qt/qt_runtime.cpp:320:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:344:  Missing space before ( in while(  [whitespace/parens] [5]
WebCore/bridge/qt/qt_runtime.cpp:639:  This { should be at the end of the previous line  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:638:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:749:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:791:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:792:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:793:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:794:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:804:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:805:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:806:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:807:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:808:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:809:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:810:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:811:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:812:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:827:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:834:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:835:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:839:  Missing space after ,  [whitespace/comma] [3]
WebCore/bridge/qt/qt_runtime.cpp:913:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:945:  Missing space after ,  [whitespace/comma] [3]
WebCore/bridge/qt/qt_runtime.cpp:984:  This { should be at the end of the previous line  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:1021:  More than one command on the same line  [whitespace/newline] [4]
WebCore/bridge/qt/qt_runtime.cpp:1053:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1061:  This { should be at the end of the previous line  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:1078:  Missing spaces around =  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:1149:  Missing space before ( in foreach(  [whitespace/parens] [5]
WebCore/bridge/qt/qt_runtime.cpp:1158:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/bridge/qt/qt_runtime.cpp:1184:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/bridge/qt/qt_runtime.cpp:1187:  One line control clauses should not use braces.  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:1246:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/bridge/qt/qt_runtime.cpp:1245:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1254:  One line control clauses should not use braces.  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:1273:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/bridge/qt/qt_runtime.cpp:1336:  Missing spaces around =  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:1392:  Declaration has space between type name and * in QObject *obj  [whitespace/declaration] [3]
WebCore/bridge/qt/qt_runtime.cpp:1395:  Declaration has space between type name and * in void *qargs  [whitespace/declaration] [3]
WebCore/bridge/qt/qt_runtime.cpp:1425:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1542:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1552:  Declaration has space between type name and * in JSObject *asObj  [whitespace/declaration] [3]
WebCore/bridge/qt/qt_runtime.cpp:1569:  One line control clauses should not use braces.  [whitespace/braces] [4]
WebCore/bridge/qt/qt_runtime.cpp:1570:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1577:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1583:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1605:  An else should appear on the same line as the preceding }  [whitespace/newline] [4]
WebCore/bridge/qt/qt_runtime.cpp:1598:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
WebCore/bridge/qt/qt_runtime.cpp:1614:  Missing space before ( in foreach(  [whitespace/parens] [5]
WebCore/bridge/qt/qt_runtime.cpp:1709:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
WebCore/bridge/qt/qt_runtime.cpp:1710:  One space before end of line comments  [whitespace/comments] [5]
WebCore/bridge/qt/qt_runtime.cpp:1711:  One space before end of line comments  [whitespace/comments] [5]
WebCore/bridge/qt/qt_runtime.cpp:1717:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
WebCore/bridge/qt/qt_runtime.cpp:1720:  One space before end of line comments  [whitespace/comments] [5]
WebCore/bridge/qt/qt_runtime.cpp:1737:  Declaration has space between type name and * in void *QtConnectionObject  [whitespace/declaration] [3]
WebCore/bridge/qt/qt_runtime.cpp:1739:  More than one command on the same line in if  [whitespace/parens] [4]
WebCore/bridge/qt/qt_runtime.cpp:1745:  _c is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebCore/bridge/qt/qt_runtime.cpp:1745:  _id is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebCore/bridge/qt/qt_runtime.cpp:1780:  l is incorrectly named. Don't use the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/bridge/qt/qt_runtime.cpp:1784:  Missing spaces around =  [whitespace/operators] [4]
WebCore/bridge/qt/qt_runtime.cpp:1784:  Missing space before ( in for(  [whitespace/parens] [5]
WebCore/bridge/qt/qt_runtime.cpp:1839:  Extra space before ( in function call  [whitespace/parens] [4]
WebCore/bridge/qt/qt_runtime.cpp:1858:  One line control clauses should not use braces.  [whitespace/braces] [4]
Total errors found: 77 in 1 files

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list