[Webkit-unassigned] [Bug 39083] Refactor FormData and Blob for better support of Blobs synthesized by BlobBuilder

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 25 22:57:44 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39083





--- Comment #43 from Kinuko Yasuda <kinuko at chromium.org>  2010-05-25 22:57:42 PST ---
(In reply to comment #41)
> (From update of attachment 57018 [details])
> WebCore/platform/BlobItem.cpp:74
>  +  char* DataBlobItem::deepCopyBuffer() const
> Probably copyBuffer() sounds simpler.

Renamed.

> WebCore/platform/BlobItem.cpp:111
>  +  bool FileBlobItem::isValid() const
> This validity check is not necessary because the check is done when we open a file to read.
> Please also remove isValid() from FileBlobItem class definition.

Removed FileBlobItem::isValid().

> WebCore/platform/BlobItem.cpp:141
>  +  
> Please remove the extra empty line.

Done.

> WebCore/platform/network/FormData.cpp:171
>  +  void FormData::appendBlobItemList(const BlobItemList& list)
> This method is very confusing with appendItems because both take BlobItemList and the names sound similar while the semantics are very different.
> How about naming this method as appendItems (or appendBlobItems) and the other one as appendKeyValuePairItems (or appendBlobItemsInKeyValuePair)?

Sounds good, renamed the other private method to appendKeyValuePairItems.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list