[Webkit-unassigned] [Bug 39329] [WinCairo] Correct scaling for print preview

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 20 06:47:49 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39329


Adam Roben (aroben) <aroben at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #56425|review?                     |review+
               Flag|                            |




--- Comment #4 from Adam Roben (aroben) <aroben at apple.com>  2010-05-20 06:47:49 PST ---
(From update of attachment 56425)
WebKit/win/ChangeLog:8
 +          Cairo does not properly deal with Windows HDC's that have been
There's no apostrophe in "HDCs".

WebKit/win/ChangeLog:13
 +          Instead, reset the HDC's WorldTransform to unity, scale the
Here, too.

I think maybe you mean "identity" instead of "unity".

WebKit/win/WebFrame.cpp:2166
 +      int y = max(static_cast<int>(headerHeight) + pageRect.height(), m_pageHeight  -static_cast<int>(footerHeight));
Weird spacing around the - operator here.

WebKit/win/WebFrame.cpp:2172
 +  static XFORM buildXformFromCairo(HDC targetDC, cairo_t* cr)
I think WebKit naming conventions say this should be buildXFORMFromCairo.

Is there a better name we can use than "cr"?

WebKit/win/WebFrame.cpp:2247
 +  static void setCairoToHDC(cairo_t* cr, HDC targetDC)
Again, a better name than "cr" would be nice.

I agree that this function could use a better name.

WebKit/win/WebFrame.cpp:2252
 +      XFORM revertedCTM(passedCTM);
Using constructor syntax here is a little surprising.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list