[Webkit-unassigned] [Bug 39289] Wrong result in case of non-iterative matching of subpatterns in non-greedy cases in YARR Interpreter

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 19 07:40:30 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39289


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #56489|review?, commit-queue?      |review+, commit-queue+
               Flag|                            |




--- Comment #5 from Darin Adler <darin at apple.com>  2010-05-19 07:40:28 PST ---
(From update of attachment 56489)
> -                    output[(subpatternId << 1) + 1] = input.getPos() + term.inputPosition;
> +                    output[(subpatternId << 1)] = input.getPos() + term.inputPosition;

I suggest omitting the parentheses here. output[subpatternId << 1] would be easier to read.

> +        The backtrackParentesesOnceEnd function should store the start position

Typo here in the name of the function.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list