[Webkit-unassigned] [Bug 38982] [Chromium] Support icon loading for <input type=file>

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 18 22:13:24 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38982





--- Comment #6 from Kent Tamura <tkent at chromium.org>  2010-05-18 22:13:23 PST ---
(In reply to comment #2)
> (From update of attachment 55828 [details])
> WebKit/chromium/public/WebIconLoadingCompletion.h:45
>  +      virtual void iconLoaded(const WebData&) = 0;
> nit: name this didLoadIcon for consistency with WebFileChooserCompletion::didChooseFile.

Renamed it to didLoadIcon().

> is there a reason why this data stream has to be a PNG?  it can't be a different image
> format?

No reason.  It accepts any bitmap image formats which WebCore::Image can handle.  I updated the comment.

> WebKit/chromium/public/WebViewClient.h:108
>  +  
> nit: please preserve the two new lines before a section comment

Fixed.

> WebKit/chromium/public/WebViewClient.h:107
>  +      virtual bool chooseIconForFiles(const WebVector<WebString>& filenames, WebIconLoadingCompletion*) { return false; }
> nit: using the word "choose" in this method suggests that the user
> will be prompted to make a choice.  i don't think this is what you
> intend.  maybe queryIconForFiles would be better.

Renamed it to queryIconForFiles().

> is there a reason why this needs to be a method on WebViewClient?
> it seems more like a platform thing that wouldn't vary depending
> on the WebView.  should this be part of WebKitClient instead?

See my prior comments please.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list