[Webkit-unassigned] [Bug 39081] [chromium] Adds supports for layout tests using GeolocationServiceMock

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 14 02:09:34 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39081





--- Comment #3 from Steve Block <steveblock at google.com>  2010-05-14 02:09:34 PST ---
(From update of attachment 56011)
Can you explain why this is needed? As far as I can see, GeolocationServiceChromiumMock is an intermediate that sits between the existing GeolocationServiceMock and the Geolocation object. Does this class exist solely to add the extra calls to GeolocationServiceChromium::startUpdating()/stopUpdating()?

It looks like GeolocationServiceChromiumMock is mostly boilerplate - could it be reduced by having it inherit from GeolocationServiceMock, rather than owning an instance?

> diff --git a/WebCore/platform/GeolocationService.cpp b/WebCore/platform/GeolocationService.cpp
> +void GeolocationService::useMockFactory(FactoryFunction f)
> +{
> +    s_mockFactoryFunction = f;
> +    useMock();
>  }
So we need to call useMock() here, as it's called from setPosition and setError? Would a better name for this function then be 'setCustomMock'?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list