[Webkit-unassigned] [Bug 37945] CMake buildsystem

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 12 13:31:41 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=37945





--- Comment #21 from Patrick R. Gansterer <paroga at paroga.com>  2010-05-12 13:31:40 PST ---
(In reply to comment #18)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > I think it should be done via FindXXX.
> > > Many of the 3rdparty libs like libxml, sqlite, ... are used on other ports too, so the FindXXX can be reused then.
> > > Most of the FinXXX you'll need exist already.
> > 
> > I agree.  The SQLITE one exists for sure.
> 
> Are you sure? At least in Cmake 2.8 it does not. Is there any repository of unofficial/3rd party FindXXX.cmake out there? For instance, a quick research of our needs do not exist in Cmake 2.8:
Sorry, wrong example! ;-)

> GLIB (although there are GTK and GTK2)
GTK2 works with my GTK port. I think it will work for EFL too.

> CAIRO
http://zi.fi/cmake/Modules

> SQLITE3
http://websvn.kde.org/trunk/KDE/kdelibs/cmake/modules/

> How should we proceed? Create FindXXX.cmake for all of them or just the first part?
I think you should do all with the FinXXX.cmake. Maybe you can do only one FindEFL.cmake for EINA, EET, EVAS, ECORE, EMBRYO and EDJE since they are only used by the EFL port.

> CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
If you need 2.8 only because of the FindXXX you should add them into the cmake directory. Not all linux distributions ship with 2.8 already.

> > Each port might want to define different names for these libraries. For instance, the EFL port creates a libewebkit.so under Unix; the GTK+ port might want to create a libwebkitgtk.so and so on.
> Ok, makes sense! ;-)
I think we should rename it to TARGET_NAME (JavaScriptCore_LIBRARY_NAME -> JavaScriptCore_TARGET_NAME). E.g. JSC isn't a library.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list