[Webkit-unassigned] [Bug 38982] [Chromium] Support icon loading for <input type=file>

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 12 11:13:31 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38982


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #55828|review?                     |review-
               Flag|                            |




--- Comment #2 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-05-12 11:13:30 PST ---
(From update of attachment 55828)
WebKit/chromium/public/WebIconLoadingCompletion.h:45
 +      virtual void iconLoaded(const WebData&) = 0;
nit: name this didLoadIcon for consistency with WebFileChooserCompletion::didChooseFile.
is there a reason why this data stream has to be a PNG?  it can't be a different image
format?

WebKit/chromium/public/WebViewClient.h:108
 +  
nit: please preserve the two new lines before a section comment

WebKit/chromium/public/WebViewClient.h:107
 +      virtual bool chooseIconForFiles(const WebVector<WebString>& filenames, WebIconLoadingCompletion*) { return false; }
nit: using the word "choose" in this method suggests that the user
will be prompted to make a choice.  i don't think this is what you
intend.  maybe queryIconForFiles would be better.

is there a reason why this needs to be a method on WebViewClient?
it seems more like a platform thing that wouldn't vary depending
on the WebView.  should this be part of WebKitClient instead?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list