[Webkit-unassigned] [Bug 38683] SVG FilterEffects need more detailed DRT information

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 6 22:43:00 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38683





--- Comment #6 from Dirk Schulze <krit at webkit.org>  2010-05-06 22:43:00 PST ---
(In reply to comment #4)
> (From update of attachment 55294 [details])
> WebCore/platform/graphics/filters/FEBlend.cpp:163
>  +      case FEBLEND_MODE_DARKEN:
> I prefer to write this sort of code in terms of helper functions which convert
> from the ENUM to a char*.  That would simplify this code slightly and make it
> easier to re-use.
> 
> WebCore/platform/graphics/filters/FEColorMatrix.cpp:202
>  +          ts << "UNKNOWN";
> Again here. :)
> 
> WebCore/platform/graphics/filters/FEColorMatrix.cpp:226
>  +      if (!m_values.isEmpty()) {
> I would have also made this a separate function... but I'm all crazy about
> using lots of little inlines. :)
> 
> WebCore/platform/graphics/filters/FEColorMatrix.h:54
>  +          TextStream& externalRepresentation(TextStream& ts, int indent)
> const;
> no "ts" needed.
> 
> WebCore/platform/graphics/filters/FEComponentTransfer.cpp:220
>  +      ts << "{red:   type=\"" << m_redFunc.type << "\" slope=\""
> Should use a helper function. :)
> 
> 
> only looked through the first little bit, but there is more cleanup needed
> here.  The copy/paste with the m_redFunc stuff is r-. :(

Also I don't find it usefull to make the DRT output longer on using
FEBLEND_MODE_DARKEN instead of just DARKEN, the type is clear and also the
effect name. Using the complete name doesn't give more information, but makes
the code harder to read because of the longer lines and the fewer differences
between the values. All would begin with FEBLEND_MODE_.
But the comment about FEComponentTransfer.cpp is correct. Will invastigate in
this.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list