[Webkit-unassigned] [Bug 38618] Ban the single letter 'l' as a variable name

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 5 17:59:58 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38618





--- Comment #2 from James Robinson <jamesr at chromium.org>  2010-05-05 17:59:58 PST ---
This warning trips 71 times in WebCore/ as of r58839.  I can either clean these
up proactively with a set of follow-up patches or just let them get cleaned up
organically.  Here's a list:


WebCore/bridge/qt/qt_runtime.cpp:1780:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSComputedStyleDeclaration.cpp:347:  l is incorrectly named. Don't
use the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:2824:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:2950:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:3240:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:3872:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:4953:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5137:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5151:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5207:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5221:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5532:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5556:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/css/CSSStyleSelector.cpp:5744:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/dom/Document.cpp:2694:  l is incorrectly named. Don't use the single
letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/dom/Document.cpp:4466:  l is incorrectly named. Don't use the single
letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/dom/QualifiedName.cpp:54:  l is incorrectly named. Don't use the single
letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/dom/QualifiedName.h:117:  l is incorrectly named. Don't use the single
letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/dom/StyledElement.cpp:306:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/html/HTMLFormCollection.cpp:81:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/html/HTMLParser.cpp:463:  l is incorrectly named. Don't use the single
letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/html/HTMLParser.cpp:507:  l is incorrectly named. Don't use the single
letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/efl/RenderThemeEfl.cpp:499:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/Color.h:66:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/Color.h:101:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/FloatRect.cpp:65:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/FloatRect.cpp:94:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/FloatRect.cpp:115:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/IntRect.cpp:59:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/IntRect.cpp:88:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/cg/IntRectCG.cpp:42:  l is incorrectly named. Don't
use the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/platform/graphics/transforms/TransformationMatrix.cpp:266:  l is
incorrectly named. Don't use the single letter 'l' as an identifier name. 
[readability/naming] [4]
WebCore/platform/graphics/wince/GraphicsContextWince.cpp:130:  l is incorrectly
named. Don't use the single letter 'l' as an identifier name. 
[readability/naming] [4]
WebCore/platform/image-decoders/gif/GIFImageReader.cpp:410:  l is incorrectly
named. Don't use the single letter 'l' as an identifier name. 
[readability/naming] [4]
WebCore/rendering/RenderBlock.cpp:4775:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderBlock.cpp:4824:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderBox.cpp:423:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderInline.cpp:1010:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderLayer.cpp:481:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderLayer.cpp:492:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderLayer.cpp:833:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderLayer.cpp:835:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderLayer.cpp:862:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderLayer.cpp:3108:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderObject.cpp:1582:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderScrollbarPart.cpp:80:  l is incorrectly named. Don't
use the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderText.cpp:1345:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderThemeChromiumSkia.cpp:292:  l is incorrectly named.
Don't use the single letter 'l' as an identifier name.  [readability/naming]
[4]
WebCore/rendering/RenderThemeChromiumSkia.cpp:313:  l is incorrectly named.
Don't use the single letter 'l' as an identifier name.  [readability/naming]
[4]
WebCore/rendering/RenderTreeAsText.cpp:456:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderTreeAsText.cpp:470:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderTreeAsText.cpp:523:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/RenderTreeAsText.cpp:636:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/FillLayer.h:95:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/FillLayer.h:96:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/FillLayer.h:104:  l is incorrectly named. Don't use the
single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/NinePieceImage.h:61:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:745:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:776:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:777:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:779:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:824:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:890:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:891:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:892:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:964:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:1004:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:1005:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:1030:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/RenderStyle.h:1031:  l is incorrectly named. Don't use
the single letter 'l' as an identifier name.  [readability/naming] [4]
WebCore/rendering/style/StyleReflection.h:53:  l is incorrectly named. Don't
use the single letter 'l' as an identifier name.  [readability/naming] [4]

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list