[Webkit-unassigned] [Bug 38465] New: Misleading variable name in a11y test

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 3 07:58:45 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38465

           Summary: Misleading variable name in a11y test
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: All
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: Tools / Tests
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: msanchez at igalia.com


In LayoutTests/accessibility/aria-controls-with-tabs.html, the variable 'body'
is misleading, because it actually contain the root accessible element, not the
accessible object associated to the <body> tag:

  var body = accessibilityController.rootElement;

If you compare this with other a11y tests using the rootElement method, it's
done in a different, but more understandable, way. For instance, in
LayoutTests/platform/mac/accessibility/element-focus.html:

  var root = accessibilityController.rootElement;
  var body = root.childAtIndex(0);

In the case of aria-controls-with-tabs.html, the test is still working fine
because at the end 'body' is not being used as if it were the a11y object for
body, but its parent:

    var body = accessibilityController.rootElement;
    var tabList = body.childAtIndex(0).childAtIndex(0);


Hence, even though it's working fine because of the thing pointed out above,
IMHO it would be better if the test was written more like
LayoutTests/platform/mac/accessibility/element-focus.html

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list