[Webkit-unassigned] [Bug 36527] Need an ASSERT that's enabled in release builds

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 24 06:14:12 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=36527


Jeremy Orlow <jorlow at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |crogers at google.com




--- Comment #1 from Jeremy Orlow <jorlow at chromium.org>  2010-03-24 06:14:12 PST ---
I definitely agree.  For example, I'm reviewing audio code that has ASSERTs for
sanity checks on buffer lengths.  If there is some bad assumption that would
cause us to exceed our buffer, we'd much rather crash rather than allow a
possible exploit.  But it doesn't make sense to add complex error code paths
for stuff that should never happen.  So instead I've been suggesting adding |if
(...) CRASH();|s.  I think having a proper macro would be beneficial though.

Another example of where this is useful is
https://bugs.webkit.org/show_bug.cgi?id=36426 where Jeremy (the other one)
added some debug code to the Chromium WebKit API to try and expose a bug.

Any thoughts on the best name for this?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list