[Webkit-unassigned] [Bug 36232] [Qt] User name/password stripped from URLs

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 22 16:12:28 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=36232





--- Comment #4 from Simon Hausmann <hausmann at webkit.org>  2010-03-22 16:12:28 PST ---
(In reply to comment #3)
> (In reply to comment #2)
> > AFAICS d and the return value of getInternal() point to the same thing:
> > ResourceHandle's private data pointer.
> > 
> > I agree the last call to getInternal() is redundant, but otherwise I don't see
> > the bug. What am I missing?
> 
> That I'm getting mislead by my debugger.  I think that the actual bug might be
> the if statement on 134:
> 
> if (!(d->m_user.isEmpty() || d->m_pass.isEmpty())
> 
> If a username is provided but not a password (which is my case), if (!(false ||
> true)) == if (!(true)) == if (false).  Should this and other user/password
> checks be:
> 
> if (!(d->m_user.isEmpty() && d->m_pass.isEmpty())

Yes, exactly! :)

Or slightly more readable:

    if (!d->m_user.isEmpty() || !d->m_pass.isEmpty()) {


Want to make a patch with ChangeLog and testcase/unit test in WebKit/qt/tests?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list