[Webkit-unassigned] [Bug 35072] [Mac] Move Icon::iconForFiles() code to WebChromeClient::iconForFiles().

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 19 08:12:32 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=35072





--- Comment #8 from Darin Adler <darin at apple.com>  2010-03-19 08:12:32 PST ---
(From update of attachment 51121)
> -void ChromeClient::iconForFiles(const Vector<WebCore::String>&, PassRefPtr<WebCore::FileChooser>)
> +void ChromeClient::iconForFiles(const Vector<WebCore::String>& filenames, PassRefPtr<WebCore::FileChooser> chooser)

This function name is not good. The function doesn't return an icon, so it
shouldn't be named "icon". I suggest the name chooseIconForFiles.

The argument types on this function may also be wrong. A function should only
take a PassRefPtr if it's taking ownership of an object. This function does not
take ownership of the FileChooser object.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list