[Webkit-unassigned] [Bug 34942] Fullscreen API naming is inconsistent

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 12 17:17:15 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=34942


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #50643|review?                     |review+
               Flag|                            |




--- Comment #4 from Simon Fraser (smfr) <simon.fraser at apple.com>  2010-03-12 17:17:15 PST ---
(From update of attachment 50643)
> Index: WebCore/html/HTMLVideoElement.idl
> ===================================================================
> --- WebCore/html/HTMLVideoElement.idl	(revision 55928)
> +++ WebCore/html/HTMLVideoElement.idl	(working copy)
> @@ -33,6 +33,10 @@ module html {
>  
>          readonly attribute boolean webkitSupportsFullscreen;
>          readonly attribute boolean webkitDisplayingFullscreen;
> +
> +        [NeedsUserGestureCheck] void webkitEnterFullscreen()
> +            raises (DOMException);
> +        void webkitExitFullscreen();
>      
>          [NeedsUserGestureCheck] void webkitEnterFullScreen()
>              raises (DOMException);

I think you file a bugzilla to remove the old versions, and add a comment
referencing it.

> Index: WebKit/mac/ChangeLog
> ===================================================================
> --- WebKit/mac/ChangeLog	(revision 55944)
> +++ WebKit/mac/ChangeLog	(working copy)
> @@ -1,3 +1,31 @@
> +2010-03-12  Beth Dakin  <bdakin at apple.com>
> +
> +        Reviewed by NOBODY (OOPS!).
> +
> +        Fix for https://bugs.webkit.org/show_bug.cgi?id=34942 Fullscreen 
> +        API naming is inconsistent
> +        -and corresponding-
> +        <rdar://problem/7729165>
> +
> +        This patch changes all occurrences of "fullScreen" to the more 
> +        popular "fullscreen."
> +
> +        * Plugins/Hosted/NetscapePluginHostProxy.h:
> +        (WebKit::NetscapePluginHostProxy::isFullscreenWindowShowing):
> +        * Plugins/Hosted/NetscapePluginHostProxy.mm:
> +        (WebKit::NetscapePluginHostProxy::NetscapePluginHostProxy):
> +        (WebKit::NetscapePluginHostProxy::didEnterFullscreen):
> +        (WebKit::NetscapePluginHostProxy::didExitFullscreen):
> +        (WebKit::NetscapePluginHostProxy::setFullscreenWindowIsShowing):
> +        (WKPCSetFullscreenWindowIsShowing):
> +        * Plugins/Hosted/WebKitPluginClient.defs:
> +        * Plugins/WebNetscapePluginView.mm:
> +        (-[WebNetscapePluginView _workaroundSilverlightFullscreenBug:]):
> +        (-[WebNetscapePluginView _createPlugin]):
> +        (-[WebNetscapePluginView _destroyPlugin]):
> +        * WebView/WebVideoFullscreenHUDWindowController.mm:
> +        (-[WebVideoFullscreenHUDWindowController windowDidLoad]):

I think it's fine if you don't change the plugin-related code in this patch; up
to you.

r=me

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list