[Webkit-unassigned] [Bug 35844] [Qt] Add support for LayoutTestController commands.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 8 20:54:40 PST 2010


--- Comment #4 from Holger Freyther <zecke at selfish.org>  2010-03-08 20:54:40 PST ---
(In reply to comment #3)
> (In reply to comment #2)
> > The patch is fine, for the API it might be better to have an enum for each
> > command and then a generic isCommandEnabled, setCommandEnabled function?
> There isn't a setCommandEnabled function required by the LayoutTestController.
> Also, isCommandEnabled is only ever called by the DRT so not sure of value of
> enumerating every valid command since those are already enumerated by WebCore.
> Have a feeling I've missed your point though.

The point is. You will be adding ~10-15 public API methods (setters and
getters) that have little usage outside of the DRT. This raises my concern that
this might be the wrong approach.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list