[Webkit-unassigned] [Bug 41010] [chromium] Attach a GLES2Context to a WebView to enable resource sharing

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 23 11:13:33 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=41010





--- Comment #9 from Vangelis Kokkevis <vangelis at chromium.org>  2010-06-23 11:13:33 PST ---
(In reply to comment #7)
> (From update of attachment 59459 [details])
> WebKit/chromium/src/GLES2Context.cpp:68
>  +      WebKit::WebViewImpl* webView = WebKit::WebViewImpl::fromPage(page);
> I recommend putting a "using namespace WebKit" at the top of this file.
> 
Done.

> WebKit/chromium/src/WebViewImpl.h:340
>  +      WebGLES2Context* GLES2Context();
> WebKit style suggests that this method should be named gles2Context
> instead.  See examples like ResourceRequest::httpReferrer.
> 
Done.

> WebKit/chromium/src/WebViewImpl.cpp:2290
>  +      if (!m_gles2Context) {
> should we check if accelerated compositing is enabled before
> creating the GLES2Context?

This method currently gets called from one of two places:
1. When creating a WebGL context, only if the accelerated compositing flag is enabled
2. When creating the page compositor

So, as it stands, it will only create the context if compositing is enabled.  However, one can imagine other cases where it would be useful to attach a GLES2 context to the view even when not doing accelerated compositing so I don't think it should be checking whether the feature is enabled.
I had previously made a mistake and defined the method within the USE(ACCELERATED_COMPOSTING) block which shouldn't be the case.  It's fixed in this patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list