[Webkit-unassigned] [Bug 40940] Add message passing support to the WebKit2 API

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 21 14:11:09 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40940





--- Comment #3 from Anders Carlsson <andersca at apple.com>  2010-06-21 14:11:09 PST ---
(From update of attachment 59284)
> Index: WebKit2/ChangeLog
> ===================================================================
> --- WebKit2/ChangeLog	(revision 61572)
> +++ WebKit2/ChangeLog	(working copy)
> @@ -1,3 +1,55 @@
> +2010-06-21  Sam Weinig  <sam at webkit.org>
> +
> +        Reviewed by NOBODY (OOPS!).
> +
> +        Patch for https://bugs.webkit.org/show_bug.cgi?id=40940
> +        Add message passing support to the WebKit2 API.
> +        
> +        Adds message passing for both InjectedBundle -> WebContex 
> +        and WebContex -> InjectedBundle.
> +

Tyop, "contex".

> +
> +// Messages sent from the web process to the WebProcessProxy.

Should this say "from the WebProcess"?

>  
> +void WebProcess::postMessageToInjectedBundle(const String& message)
> +{
> +    if (!m_injectedBundle)
> +        return;
> +
> +    m_injectedBundle->didRecieveMessage(message);
> +}

I think this should be named forwardMessageToInjectedBundle.

Looks good otherwise, r=me

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list