[Webkit-unassigned] [Bug 28272] WINCE PORT: graphics files only for WINCE

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jun 19 09:29:54 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=28272


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #53310|review?                     |review-
               Flag|                            |




--- Comment #7 from Kent Tamura <tkent at chromium.org>  2010-06-19 09:29:54 PST ---
(From update of attachment 53310)
WebCore/platform/graphics/wince/SharedBitmap.cpp:86
 +  PassRefPtr<SharedBitmap> SharedBitmap::createInstance(bool is16bit, int w, int h, bool initPixels)
One letter variable names are not good.


WebCore/platform/graphics/wince/SharedBitmap.cpp:88
 +      SharedBitmap* rtn = new SharedBitmap(is16bit, w, h, initPixels);
"rtn" is not good name.  resultantBitmap?


WebCore/platform/graphics/wince/SharedBitmap.cpp:109
 +  SharedBitmap::SharedBitmap(bool _is16bit, int w, int h, bool initPixels)
_is16bit should be is16bit.  w and h should be width and height.


WebCore/platform/graphics/wince/SharedBitmap.cpp:143
 +      if (m_pixels) {
We prefer early exit in WebKit. So this should be:
if (!m_pixels)
    return;


WebCore/platform/graphics/wince/SharedBitmap.cpp:246
 +  HBITMAP SharedBitmap::createHandle(void** pixels, BitmapInfo* bmpInfo, int h, bool use16bit) const
One letter variable name is not good.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list