[Webkit-unassigned] [Bug 39624] --squash should go away and become the default

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 11 14:54:29 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39624





--- Comment #26 from Eric Seidel <eric at webkit.org>  2010-06-11 14:54:28 PST ---
(From update of attachment 57833)
WebKitTools/Scripts/webkitpy/common/checkout/scm.py:101
 +          self._user = User()
Um... Do we really want SCM to be able to interact with the user?  I'm wondering if this is a layering violation.

WebKitTools/Scripts/webkitpy/common/checkout/scm.py:580
 +          return """There are %s local commits%s. Everything will be committed as a single commit. To avoid this prompt, set "git config webkit-patch.squash true". Continue?""" % (num_local_commits, working_directory_message)
This is hard to read as one line. 

WebKitTools/Scripts/webkitpy/common/checkout/scm.py:583
 +          squash = Git.read_git_config('webkit-patch.squash')
Should this be webkit-patch.commit_should_always_squash instead?  Does .squash mean multiple things?  This commit behavior seems possibly destructive where as other meanings of .squash could be less so.

WebKitTools/Scripts/webkitpy/common/checkout/scm.py:599
 +          if not self.commit_should_always_squash():
Seems this could be its own function. :)

WebKitTools/Scripts/webkitpy/common/checkout/scm.py:604
 +                  raise ScriptError(message="Did not commit")
Confused.

WebKitTools/Scripts/webkitpy/tool/steps/preparechangelog.py:57
 +          if self._tool.scm().support_local_commits():
Does this need to check _options.git_commit first?

Big change for my little brain... :(

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list