[Webkit-unassigned] [Bug 25645] SVG - numeric overflow for very large elements

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 11 07:56:39 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=25645


Nikolas Zimmermann <zimmermann at kde.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #58472|review?                     |review-
               Flag|                            |




--- Comment #50 from Nikolas Zimmermann <zimmermann at kde.org>  2010-06-11 07:56:36 PST ---
(From update of attachment 58472)
Hi W. James, still r-, sorry:

ChangeLog order is wrong again. Your comments have to go below the bug number & description, just have a look at WebCore/ChangeLog to see how it works.
Also the ChangeLog entries are confusing. You've basically added a line for every new patch you've uploaded here, instead you should only the describe the "final patch"

> +        Revised safeIntToFloat() to use values from <limits>.
> +
> +        Fixed two test outputs involving large coordinate values.
> +
> +        Two of the expected test outputs were incorrect now that parsing of large values
> +        is handled correctly.
> +
> +        Revised to improve variable names in enclosingIntRect(), _parseNumber(), and fix style issues.
> +
> +        - Revised FloatRect to remove bad float-to-int conversions in enclosingIntRect()
> +        - Revised _parseNumber to do right-to-left float-based parsing of input value

Just use:

> +        Two of the expected test outputs were incorrect now that parsing of large values
> +        is handled correctly.
> +        - Revised FloatRect to remove bad float-to-int conversions in enclosingIntRect()
> +        - Revised _parseNumber to do right-to-left float-based parsing of input value


> +static inline int safeFloatToInt(float x)
> +{
> +    static int intMax = std::numeric_limits<int>::max();
> +    static int intMin = std::numeric_limits<int>::min();

Recently the naming of these statics has been discussed on webkit-dev: use s_intMax, s_intMin here.

Other than those last two issues, it's r+ :-)
You must hate me by now, sorry for the numerous of reiterations ;-)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list