[Webkit-unassigned] [Bug 40372] CodeGeneratorJS.pm incorrectly increments $paramIndex when a method is declared with [CallWith]

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 10 02:18:09 PDT 2010


--- Comment #3 from Jeremy Orlow <jorlow at chromium.org>  2010-06-10 02:18:07 PST ---
(From update of attachment 58266)
No show stoppers, but a bunch of things I think could be better/cleaner.

 +      doCreateOrOpen(function() { return db.createObjectStore('storeName', 'keyPath'); }, createSuccess);
Why evaluate this as a function?  You might as well just pass the IDBResult into it.  That said, I actually don't think that helper function is worth the code obfuscation.

 +  function openSuccess()
You should put these functions in some sort of order.  RIght now you jump from bottom to top to second from the bottom to second from the top.  Linear is probably easiest to read, though from the bottom up would work as well.

 +      shouldBeEqualToString("store.keyPath", "keyPath");
Put fixmes for the other stuff that needs to be done.

 +  function doCreateOrOpen(func, successHandler)
Instead of a 'doCreateOrOpen' we really need to clean up the environment before we start.  For now, just put in a 'FIXME' to clean up before we start and put a debug comment explaining that it'll only work once per instance of WebKit.

We should add a way to enumerate databases to the spec to make this easier.  (I already talked to nikunj about this and convinced him, so it's mostly a matter of doing it.)

 +                      my $argsIndex = 0;
$argsIndex and $paramIndex aren't the most clear names.  Maybe even just $inParamIndex and $outParamIndex would be better.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list