[Webkit-unassigned] [Bug 40134] Web Inspector: sendMessageToFrontend implementation required.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 8 12:51:23 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40134





--- Comment #19 from Pavel Feldman <pfeldman at chromium.org>  2010-06-08 12:51:21 PST ---
(From update of attachment 58139)
WebCore/inspector/InspectorClient.h:45
 +      virtual void closeInspectorFrontend() = 0;
This one is no longer used and can go away, right?


WebCore/inspector/front-end/inspector.js:575
 +  WebInspector.dispatchMessageToFrontend = function(arguments)
Nit: I'd call it dispatchMessageFromBackend. Also, we might want to have try / catch here for the transition phase that would log into WebInspector.log.

WebCore/loader/EmptyClients.h:483
 +      virtual void closeInspectorFrontend() { }
Remove this?

WebKit/chromium/src/InspectorClientImpl.cpp:70
 +  void InspectorClientImpl::closeInspectorFrontend()
Unused?

WebKit/efl/WebCoreSupport/InspectorClientEfl.cpp:41
 +  void InspectorClientEfl::closeInspectorFrontend()
Remove?

WebKit/efl/WebCoreSupport/InspectorClientEfl.h:47
 +      virtual void closeInspectorFrontend();
ditto

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list