[Webkit-unassigned] [Bug 39879] Geolocation activity started after frame has been disconnected can cause crash

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 8 08:35:02 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=39879


Jeremy Orlow <jorlow at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #58137|review?                     |review-
               Flag|                            |




--- Comment #17 from Jeremy Orlow <jorlow at chromium.org>  2010-06-08 08:35:00 PST ---
(From update of attachment 58137)
WebCore/page/Geolocation.cpp: 
 +      // This method is called at most once on a given GeoNotifier object.
Why is this getting removed?  What happens if the timer has already started for another error?  Etc...  This probably deserves mention in the change log.



WebCore/page/Geolocation.cpp:500
 +          RefPtr<GeoNotifier> notifier = *it;
Why do you need to do this?  It doesn't seem like it saves any space.  I guess it's slightly more readable....

WebCore/page/Geolocation.cpp:508
 +      copyToVector(m_oneShots, copy);
Do you need to null out the list?

WebCore/page/Geolocation.cpp:510
 +      m_watchers.getNotifiersVector(copy);
This shouldn't have had get in the name...

WebCore/page/Geolocation.h:138
 +      void cancelAllRequests(Vector<RefPtr<GeoNotifier> >&);
Why name this the same thing and make it public?  It seems like just a helper function.

WebCore/page/Geolocation.cpp:50
 +  static const char serviceNoLongerAvailableErrorMessage[] = "Geolocation service no longer available";
Are these messages supposed to not have a period at the end?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list