[Webkit-unassigned] [Bug 40077] [Qt] Implement the simple font code path.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 4 01:47:08 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40077


Jocelyn Turcotte <jocelyn.turcotte at nokia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #57683|0                           |1
        is obsolete|                            |
  Attachment #57683|review?                     |
               Flag|                            |
  Attachment #57853|                            |review?
               Flag|                            |




--- Comment #9 from Jocelyn Turcotte <jocelyn.turcotte at nokia.com>  2010-06-04 01:47:06 PST ---
Created an attachment (id=57853)
 --> (https://bugs.webkit.org/attachment.cgi?id=57853)
Patch v2

Changes:
- Fixed style and compilation issues
- Changed the complex-calls-inside-the-simple-functions to Q_ASSERT(false) to avoid confusion. These function should not be called anyway since we called setCodePath in QWebPagePrivate::QWebPagePrivate()
- Merge the two drawText functions in one function to fix compilation issues. The readability takes a drop but I think it is better than duplicating the text shadow/pen/brush logic.
- gRoundingHackCharacterTable and stuff is still wrapped in "#if !PLATFORM(QT)" to save 256 bytes, I'm not sure it's worth it though.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list