[Webkit-unassigned] [Bug 40134] Web Inspector: sendMessageToFrontend impelementation required.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 3 13:35:05 PDT 2010


Joseph Pecoraro <joepeck at webkit.org> changed:

           What    |Removed                     |Added
  Attachment #57799|1                           |0
        is obsolete|                            |

--- Comment #4 from Joseph Pecoraro <joepeck at webkit.org>  2010-06-03 13:35:04 PST ---
(From update of attachment 57799)
> +++ b/WebCore/inspector/InspectorFrontend.cpp
> +InspectorFrontend::InspectorFrontend(ScriptObject webInspector, InspectorClient* inspectorClient)
> +    : m_webInspector(webInspector), m_inspectorClient(inspectorClient)

I think the usual style for this is:

    : m_a(a)
    , m_b(b)

> -  ASSERT(frontend);

Should we change this to ASSERT(webInspector)? Or will this be
expected to handle a case of a null ScriptCobject.

> +++ b/WebCore/inspector/InspectorFrontend.h
> +#include <wtf/RefPtr.h>
> ...
> +        void addRecordToTimeline(const RefPtr<InspectorObject>&);

Is this used in this patch? If not, I would say leave this out
for the next patch.

> +        InspectorClient* m_inspectorClient;

Likewise this is added and included in the constructor above
but it isn't used yet. I have an idea how it will be used, but
I think before this patch lands there should be another patch
showing an example usage, even if its trivial.

> +++ b/WebCore/inspector/InspectorClient.h
> + virtual bool sendMessageToFrontend(const String& message) = 0;

It might be worth mentioning what the bool return value here
means. If not a comment then certainly something in the ChangeLog.

Great work on this so far!

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list