[Webkit-unassigned] [Bug 40080] Web Inspector: better Function.prototype.bind for the internal code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 3 06:16:45 PDT 2010


--- Comment #11 from Timothy Hatcher <timothy at apple.com>  2010-06-03 06:16:44 PST ---
I don't see what the big deal is with bound.toString = function toString(). It helps the debugger and profiler in JSC. Sure we would rather have inferred names, but we don't yet. Andwho knows when we will.

I don't see any huge negatives from keeping it. The fact that we even talked about this is pretty pathetic. Just remove it and move on. (IIRC, Nikita has done this in other patches.)

Patrick, setting displayName is overkill and will make bind slower for no end user added benifit.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list