[Webkit-unassigned] [Bug 40080] Web Inspector: better Function.prototype.bind for the internal code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 3 05:30:01 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40080





--- Comment #9 from Pavel Feldman <pfeldman at chromium.org>  2010-06-03 05:29:59 PST ---
> But it wouldn't show the "original" function body anyway.
> 
> My main objection to the proposed fix is that it's misleading.  The debugger is showing you something which isn't true.  I'd be quite happy if the toString() was implemented like this though:
> 
> binded.toString = function toString() {
>     return "bound: " + func.toString();
> };

I would be totally fine with the change if we did not have this displayName already. In fact, we don't support it in v8 (and do not need to support it) since we have name inferring that works much better. I wonder if JSC guys are interested in getting rid of displayName and doing inferring as well. In that case, toString would not conflict with the displayName approach. Timothy, what do you say?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list