[Webkit-unassigned] [Bug 43250] [IndexedDB] IndexedDatabaseRequest should be called IndexedDatabase

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 30 10:38:11 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=43250


Jeremy Orlow <jorlow at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #63066|review?                     |review+
               Flag|                            |




--- Comment #2 from Jeremy Orlow <jorlow at chromium.org>  2010-07-30 10:38:11 PST ---
(From update of attachment 63066)
WebCore/CMakeLists.txt:1436
 +      storage/IDBDatabaseBackend.cpp
Wrong!

WebCore/WebCore.vcproj/WebCore.vcproj:50120
 +                  RelativePath="..\storage\IDBDatabaseBackendImpl.h"
These go first

WebKit/chromium/src/WebIDBDatabaseImpl.h:43
 +      WebIDBDatabaseImpl(WTF::PassRefPtr<WebCore::IDBDatabaseBackendInterface> databaseBackend);
delete variable name

WebCore/storage/IDBRequest.cpp:76
 +  void IDBRequest::onSuccess(PassRefPtr<IDBDatabaseBackendInterface> idbDatabaseBackend)
I think I used some different naming when I did it.  Maybe double check in here and the IDBCallback files that we're consistent.  It's fine to do that in the next renaming patch too.

WebCore/storage/IDBFactoryBackendImpl.cpp:57
 +      RefPtr<IDBDatabaseBackendInterface> databaseBackend;
I don't think Backend is needed here, but I don't really care. 


r=me

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list