[Webkit-unassigned] [Bug 41732] [Cairo] Bring behavior of paths on the Cairo GraphicsContext into line with the CoreGraphics port

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 29 14:21:09 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=41732





--- Comment #9 from Dirk Schulze <krit at webkit.org>  2010-07-29 14:21:09 PST ---
(From update of attachment 62982)
Great patch. Just one note:

> +    cairo_t* pathContext = m_data->m_pendingPath.m_cr;
> +    cairo_path_t* cairoPath = cairo_copy_path(pathContext);
> +    cairo_new_path(pathContext);
> +    cairo_append_path(cr, cairoPath);
> +    cairo_path_destroy(cairoPath);

Cany ou move this into a static function and add a comment about the intention?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list