[Webkit-unassigned] [Bug 5864] feTurbulence is not implemented

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 29 02:47:13 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=5864


Nikolas Zimmermann <zimmermann at kde.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #62876|review?                     |review-
               Flag|                            |




--- Comment #21 from Nikolas Zimmermann <zimmermann at kde.org>  2010-07-29 02:47:13 PST ---
(From update of attachment 62876)
WebCore/svg/graphics/filters/SVGFETurbulence.cpp:34
 +  #include <math.h>
Can you use <wtf/MathExtras.h> here? math.h shouldn't be used.

WebCore/svg/graphics/filters/SVGFETurbulence.cpp:212
 +              float tempPosition = component + s_perlinNoise;
Maybe rename to just 'position', looks slightly better.

WebCore/svg/graphics/filters/SVGFETurbulence.cpp:327
 +      FloatPoint point;
Can you move this declaration after the "FloatRect filterRegion = .." line.

WebCore/svg/graphics/filters/SVGFETurbulence.cpp:326
 +      int indexOfPixelChannel = 0;
This declaration could be moved right before the for loop.

WebCore/svg/graphics/filters/SVGFETurbulence.cpp:329
 +  
Newline can be removed as well.

WebCore/svg/graphics/filters/SVGFETurbulence.h:41
 +      static PassRefPtr<FETurbulence> create(TurbulanceType, float, float, int, float, bool);
Header indention is still wrong :-)

Almost there, r- for the issues above.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list